trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: August 2017

Re: [trinity-users] Smplayer failing to start

From: Slávek Banko <slavek.banko@...>
Date: Fri, 18 Aug 2017 16:33:25 +0200
Dne pá 18. srpna 2017 Stefan Krusche napsal(a):
> Hello everyone,
>
> on my system smplayer doesn't start from TDE. In ~/.xsession-errors is
> this error log:
>
> TQPaintDevice: Must construct a TQApplication before a TQPaintDevice
> [WARNING] Qt4 >= Qt 4.8.0 detected; you are likely affected by these
> Qt4 bugs: [WARNING]
> https://bugreports.qt-project.org/browse/QTBUG-25896 [WARNING]
> https://bugreports.qt-project.org/browse/QTBUG-26013 [WARNING] There is
> no known workaround for this problem; your Qt4 application will display
> with numerous graphical glitches.
> Das ist SMPlayer Version 17.7.0 (revision 8599), ausgeführt auf Linux
> [WARNING] Qt4 >= Qt 4.8.0 detected; you are likely affected by these
> Qt4 bugs: [WARNING]
> https://bugreports.qt-project.org/browse/QTBUG-25896 [WARNING]
> https://bugreports.qt-project.org/browse/QTBUG-26013 [WARNING] There is
> no known workaround for this problem; your Qt4 application will display
> with numerous graphical glitches.
>
> when I start smplayer in konsole I get this error message:
>
> [WARNING] Qt4 >= Qt 4.8.0 detected; you are likely affected by these
> Qt4 bugs: [WARNING]
> https://bugreports.qt-project.org/browse/QTBUG-25896 [WARNING]
> https://bugreports.qt-project.org/browse/QTBUG-26013 [WARNING] There is
> no known workaround for this problem; your Qt4 application will display
> with numerous graphical glitches.
> This is SMPlayer v. 17.7.0 (revision 8599) running on Linux
> [WARNING] Qt4 >= Qt 4.8.0 detected; you are likely affected by these
> Qt4 bugs: [WARNING]
> https://bugreports.qt-project.org/browse/QTBUG-25896 [WARNING]
> https://bugreports.qt-project.org/browse/QTBUG-26013 [WARNING] There is
> no known workaround for this problem; your Qt4 application will display
> with numerous graphical glitches.
> TQPaintDevice: Must construct a TQApplication before a TQPaintDevice
>
> These two differ only in having a different order of some of the lines
> (and the language, because my konsole is configured to have locale
> LANG=C).
>
> The warnings don't seem to be a problem as I've seen them a lot of
> times before without noticing any glitches.
>
> The system is Debian wheezy with TDE 14.04.
>
> Smplayer comes from an external repository from the MEPIS Community:
>
> $  apt-cache policy smplayer
> smplayer:
>   Installed: 17.7.0-0mcr12+1
>   Candidate: 17.7.0-0mcr12+1
>   Version table:
>  *** 17.7.0-0mcr12+1 0
>         400 http://mxrepo.com/mepiscr/repo/ mepis12cr/main amd64
> Packages 100 /var/lib/dpkg/status
>      14.9.0~ds0-1 0
>          90 http://ftp.tu-chemnitz.de/pub/linux/debian/debian/
> jessie/main amd64 Packages
>      0.8.0-1+deb7u1 0
>         500 http://ftp.tu-chemnitz.de/pub/linux/debian/debian/
> wheezy/main amd64 Packages
>
> Mepis 12 is supposed to be compatible with wheezy, though.
>
> The TQPaintDevice error is not thrown, when smplayer/14.9.0~ds0-1 is
> installed, which is from jessie.
>
> Any ideas, what the TQPaintDevice error means and what I could do to
> fix that?
>
> Regards, Stefan
>

I guess you have the qt4-tqt-theme-engine installed. Please try 
uninstalling this package. Apparently it can cause problems in some 
applications.

Cheers
-- 
Slávek