trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: August 2017

Re: [trinity-users] mime types from extensions only?

From: wofgdkncxojef <wofgdkncxojef@...>
Date: Tue, 22 Aug 2017 20:28:29 +0200

On 08/22/2017 07:13 PM, Slávek Banko wrote:
> Dne út 22. srpna 2017 wofgdkncxojef napsal(a):
>> On 08/22/2017 01:19 AM, Slávek Banko wrote:
>>> On Monday 21 of August 2017 21:11:56 wofgdkncxojef wrote:
>>>> konqueror can only tell file types from the extensions?
>>>>
>>>> I used KDE3 a long time ago, and then KDE4, so i might be confused.
>>>> I have the impression that KDE3 could tell a file type with out
>>>> depending on the extension. Right? I did something wrong with the
>>>> config, or didn't install a package? The preview of folders is a
>>>> KDE4 thing too?
>>>>
>>>> (Linux mint 18.2 mate 64bit)
>>>
>>> The libmagic library is used. However, there is one deficiency - can
>>> be recognized only mime types that are defined also
>>> in /opt/trinity/share/mimelnk.
>>>
>>> Cheers
>>
>> You mean it supposed to work with libmagic?
>> I sea a bunch of packages with libmagic in the name.
>> Some are already installed. MATE is also installed and this feature
>> works there already.
>> I'm supposed to install some extra package?
>> This is a dependency bug?
>>
> 
> The tdelibs14-trinity package depends on the libmagic1 == you have already
> installed the library. This is certainly not a problem with dependencies.
> 
> What version of Trinity have you installed - final R14.0.4 or preliminary
> R14.0.5? In R14.0.4 still had bug 2713:
> 
> https://bugs.trinitydesktop.org/show_bug.cgi?id=2713
> 
> Cheers
> 

ah... well you answered my question. :D
i'm using R14.0.4