trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: March 2018

Re: [trinity-users] Re: what can I do, uptodare wheezy, to play video3gpp2950.3g2, which claims its an mpeg4

From: Stefan Krusche <linux@...>
Date: Fri, 23 Mar 2018 11:31:08 +0100
Am Freitag 23 März 2018 schrieb Gene Heskett:
> I found this on the web at crunchbang, which says
> #4
> 2014-08-20 03:18:57
>
> hvwoax
>     New Member
>     Registered: 2014-08-20
>     Posts: 1
>
> Re: [solved] mplayer2 fails to load libraries
>
> I had just done a dist-upgrade in Sid and got the mplayer error.
> Package libdvdnav4 was installed but libdvdnav.so.4.1.2 not
> in /usr/lib/x86_64-linux-gnu!
> So I copied the symlink and the lib from the deb...
> And then did ln -s libdvdnav.so.4.1.2 libdvdnavmini.so.4
> and mplayer was back...
>
> But my copy of it is in the /usr/lib/i386-linux-gnu subdir.
>
> I'll give this a try.
>
> And I think it works, the *.* version plays something, but it wasn't the
> saved file. Clicking on the file in kmail gets me a requester or 3
> complaining about the skin, and eventually fails w/o playing the
> targeted file from a kmail click on the attachment.
>
> But the saved file does play, so the "skin" error seems to be the thing
> now.

I have a file /usr/lib/x86_64-linux-gnu/libdvdnavmini.so.4.1.2 on a Debian 
wheezy (amd64) system, but can't check now from which package it comes.

packages.debian.org gives no hit for libdvdnavmini.so in all of the newer dists 
inclusive jessie and apparently you can't search wheezy (oldoldstable) anymore.

I know I have packages installed from debian-multimedia repository as I don't 
have access to this wheezy system and maybe libdvdnav.so.4.1.2 is from one of 
them.

HTH,
Stefan