trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: November 2011

Re: [trinity-users] TDE 3..5.13 failed upgrade

From: Greg Madden <gomadtroll@...>
Date: Sat, 05 Nov 2011 11:08:00 -0800

On Saturday 05 November 2011 2:57:04 am Thierry de Coulon wrote:
> On Sat, Nov 5, 2011 at 9:21 AM, Greg Madden <gomadtroll@...> wrote:
> > FYI,
> >
> > I have been using TDE 3.5.13 nightlies in Virtualbox, Debian Squeeze
> > host, it was working great,
> >
> > I decided to upgrade my workstation, TDE 3.5.12 to 3.5.13, Debian Squeeze
> > from the nightlies server.
> >
> > Failed miserably. the upgrade/install went without a hitch, but  upon
> > starting, KDM-Trinity would crash. Never got a login scren. Removing
> > desktop-base-trinity made it possible to get a login screen.  Logging in
> > I get an error 'kdeinit failed to start' so no TDE apps worked.
> >
> > I run dual monitors and after the upgrade only one monitor would work. I
> > have a custom xorg.conf file that has been working for several releases
> > of Debian, it seems  TDE 3.5.13 handlles X differently than 3.5.12.
>
> I tried a fresh install on Ubuntu 10.04, on a machine with a somewhat
> old Nvidia 7300 (and using the nightly builds). There was no real
> problem (seems pulse audio is a little itchy) and setting up the dual
> monitors from the settings panel was a piece of cake.
>
> So i could not say of your problems are linked to the upgrade, your
> hardware, It's not clear for me either what exactly you did, as you
> say "Removing desktop-base-trinity  made it possible to get a login
> screen". But if you removed desktop-base-trinity I'am not really
> surprised that "TDE apps worked" as it seems you had just removed the
> base they needed.
>
> Thierry
 Thanks for the replies..everyone.

This is my workstation for my business, and has benn 'upgraded' through several 
Debian releases, also the previous TDE releases. The Debian component is current 
with  all security updates. I get a little anxious when things do not go well :-)

 The installation instructions do not mention upgrading, but it has not been an 
issue before. 

As far as mixing versions of TDE, aside from the fact upgrades, in my thinking,  
take care of this.  I did purge all of TDE, all versions, and did my best to get 
all the libs, which left me with my old Windowmaker install, minus TDE appps, 
then tried an 'install' of TDE 3.5.13, twice, with same results. Using the same 
purge and install, re-installed TDE 3.5.12, works  fine. 

Not sure what exactly 'desktop-base-trinity' does, but one feature is the 
background image for the login screen, TDE apps work without it in the past.

One thing I did not try, thanks for pointing this out, I use a Nvidia Quadro video 
card and use the Nvidia proprietary drive, the FOSS driver doesn't work for my 
setup. To be complete i should have  re-installed the driver.

I have a spare partition on my boot drive, I am going to do a fresh install so I 
have a failsafe work environment, then  can try 'upgrading' again paying 
attention to the video driver.

Thanks


-- 
Peace,

Greg