Message: previous - next
Month: November 2011

Re: [trinity-users] problem installing dev packages for 3.5.13

From: Laurent Dard <f.couperin@...>
Date: Sun, 13 Nov 2011 14:31:42 +0100
Le 11/11/2011 10:16, Werner Joss a écrit :
> I would like to compile kde3 stuff for trinity, without compiling all of 
> trinity first.
> so I tried to install kdelibs4-trinity-dev
> but this fails:

> what am I missing ?

It seems you have discovered a bug in the dependencies.
I tried with aptitude which is more verbose than apt-get
and I have the same problem (on wheezy/sid):

$ aptitude install kdelibs4-trinity-dev libarts1-trinity-dev libtqtinterface-dev
The following NEW packages will be installed:
  kdelibs4-trinity-dev libarts1-trinity-dev libartsc0-trinity-dev{a} libavahi-client-dev{a} libavahi-common-dev{a} libavahi-tqt-1{a} libavahi-tqt-dev{a} libglib2.0-bin{a}
  libglib2.0-dev{a} libogg-dev-la{ab} libqt3-mt-dev{ab} libtqtinterface-dev libxft-dev{a} qt3-apps-dev{a}
The following packages are RECOMMENDED but will NOT be installed:
0 packages upgraded, 14 newly installed, 0 to remove and 0 not upgraded.
Need to get 7187 kB of archives. After unpacking 31.2 MB will be used.
The following packages have unmet dependencies:
  libogg-dev-la: Depends: libogg-dev (= 1.2.0~dfsg-2) but 1.2.2~dfsg-1 is installed.
  libqt3-mt-dev: Depends: libqt3-mt (= 3:3.3.8b-11) but 3:3.3.8d-0ubuntu0+sr73+pr181~squeeze is installed.
                 Depends: libqt3-headers (= 3:3.3.8b-11) but 3:3.3.8d-0ubuntu0+sr73+pr181~squeeze is installed.
                 Depends: qt3-dev-tools (= 3:3.3.8b-11) but 3:3.3.8d-0ubuntu0+sr73+pr181~squeeze is installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     kdelibs4-trinity-dev [Not Installed]
2)     libarts1-trinity-dev [Not Installed]
3)     libavahi-tqt-dev [Not Installed]
4)     libogg-dev-la [Not Installed]
5)     libqt3-mt-dev [Not Installed]
6)     libtqtinterface-dev [Not Installed]
7)     qt3-apps-dev [Not Installed]

apt-get install libjpeg62-dev=6b1-2
apt-get install libmng-dev=1.0.10-1+b1
apt-get install libqt3-mt-dev=3:3.3.8d-0ubuntu0+sr73+pr181~squeeze
apt-get install libogg-dev=1.2.0~dfsg-2
apt-get install libogg-dev-la=1.2.0~dfsg-2
apt-get install libtiff4=3.9.4-5+squeeze3
apt-get install libtiff4-dev=3.9.4-5+squeeze3
apt-get install libtiffxx0c2=3.9.4-5+squeeze3

but now I'm stuck with libtiff4-dev=3.9.4-5+squeeze3
because it depends upon libjpeg-dev which should be provided by
libjpeg62-dev 6b1-2, but which isn't.

I think the bug is there.

Laurent Dard