trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: January 2012

Re: [trinity-users] KDE 3.5.13 up ! and Kaffeine OSD

From: "pierre.lag6633@..." <pierre.lag6633@...>
Date: Tue, 17 Jan 2012 22:22:52 +0100
hi

Indeed I have no access to bugzilla, so yes you can file this
information.

Glad it has helped in a way.
I just downloaded sources to see differences between 3.5.12 and 3.5.13
but I'm not used to object cpp programming so, it's a bit hard to
understand what to look for for me.

I was thinking that maybe the change of Qt to Tqt references have messed
up something somewhere and tried to see in a Qt configuration interface
if colors would show, but nothing comes to my eyes as a clue and I may
be on a wrong way ;).
In fact it looks like some hidden default colors are used (ugly orange
green and red mix lol ;)) .

Anyway, everything looks great for the rest :D 


Thanks again for all ;)


Le mardi 17 janvier 2012 à 10:19 -0800, Darrell Anderson a écrit :
> > Just succeeded in downloading and installing Kaffeine
> > 3.5.13 (and some other parts) on a brand new Linux
> > Mint 12 (Lisa) OS install. So thank you so much for the
> > work, it's great.
> > Only worry so far is the colours of the OSD.
> > I saw there were some posts around here http://permalink.gmane.org/gmane.comp.desktop.trinity.devel/1975
> > 
> > about that issue, but no changes in xine configuration has
> > any effect on the problem.
> > So I made some more investigations.
> > 
> > I have a 3.5.12 version rolling on the same machine on a
> > Debian Squeeze third boot disk, 
> > so I simply and roughly compare and replace some pieces to
> > see what was the origin of this presumably bug.
> > Finally, replacing only the libxinepart.so in
> > /opt/trinity/lib/trinity of Lisa by the 3.5.12 version 
> > I have in /opt/trinity/lib/kde3 of Squeeze (name of
> > directory seems to have change between these two versions)
> > changes back the OSD to its initial colours.
> > 
> > If it can help further more :
> > Squeeze version date     : sam. 14 août
> > 2010 09:29:58
> > Lisa version date     : sam. 15 oct. 2011
> > 02:35:36
> >  
> > So I presume this library has something related to that
> > issue.
> > 
> > I'm not a developer, but if I can help comparing source or
> > finding more
> > information, just let me know. I can easily compare
> > versions as they are
> > both rolling on the same machine ;).
> > 
> > Cheers and thanks so much again for your fantastic work at
> > TDE.
> 
> Bug report 727 was filed against the OSD colors. Reading the report discussion reveals the colors are estabalished in xine-part/kxinewidget.h, which is from where libxinepart.so gets built. We haven't investigated further. We still need to determine whether Qt3 is playing a role because the code in Kaffeine 3.5.13 is identical to Kaffeine 0.8.8, which I have installed in KDE 3.5.10 on the same hardware and do not experience the problem.
> 
> With your sleuthing we now can narrow the focus to a specific shared library and that helps!
> 
> Do you have access to the Bugzilla to add that information? If not then let me know and I'll add that tidbit of information.
> 
> Darrell
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: trinity-users-unsubscribe@...
> For additional commands, e-mail: trinity-users-help@...
> Read list messsages on the Web archive: http://trinity-users.pearsoncomputing.net/
> Please remember not to top-post: http://trinity.pearsoncomputing.net/mailing_lists/#top-posting
> 
>