Message: previous - next
Month: July 2012

Re: [trinity-users] libogg0 conflicts with libogg0:i386 under ubuntu precise

From: Julius Schwartzenberg <julius.schwartzenberg@...>
Date: Wed, 25 Jul 2012 11:20:56 +0200
Timothy Pearson wrote:
>> Stefan Endrullis wrote:
>>> I'm using trinity on a 64 bit Ubuntu precise (12.04) installation and
>>> I want to report a very annoying bug caused by a package conflict of
>>> libogg0 from the trinity repository:
>>> Since trinity's libogg0 conflicts with Ubuntu libogg0:i386 several 32
>>> bit applications such as adobe reader can no longer be installed on 64
>>> bit trinity installations.
>>> Is there really a conflict between libogg0 and libogg0:i386 that needs
>>> to be in the package definition or can one just remove this tag?
>> *BUMP*
>> This problem is still there and causing major issues on recent Ubuntu
>> installations. Is there any reason for Trinity to ship its own libogg0?
> Only to provide a .la file that was removed some time ago by Ubuntu
> upstream.  3.5.13 needed that file to build, R14 may not due to build
> system fixes.

Would it be possible to remove the offending packages from the
repository? This would solve all the multi-arch issues. Another option
would be adding "Multi-Arch: same".