trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: September 2012

Re: [trinity-users] Trinity not shutting down properly

From: Lisi <lisi.reisz@...>
Date: Sat, 22 Sep 2012 15:35:41 +0100
On Saturday 22 September 2012 14:55:48 Gerhard Zintel wrote:
> On Friday 21 September 2012, leee wrote:
> > On Friday 21 September 2012 15:39:37 Lisi wrote:
> > > On Friday 21 September 2012 14:40:21 Slávek Banko wrote:
> > > > Dne pá 21. září 2012 Lisi napsal(a):
> > > > > It usually gets stuck at a very early stage.  I repeat, that it
> > > > > doesn't do this every time, and if I could find a way of getting
> > > > > out of the hang without messing up my file system I could probably
> > > > > live with it. 

> > > > When it hangs, works even login on text console?
> > > > If so, kdm_greet is still running?
> > > > And if so, try to kill it: killall -9 kdm_greet.

> > > I haven't tried. 
> > > I'll watch out for a chance to try it.  Which is probably the best way
> > > possible of ensuring that it doesn't fail for days!
> > >
> > > Come to think of it I could/should have tried ssh-ing in.

> >
> > What do you see on the screen once it has stopped doing anything?  Is it
> > a blank X screen or has X closed down and dropped you back to the
> > console? If you've been dropped back to the console, are there any
> > relevant messages on the it?  If you're left with a blank X display when
> > it hangs can you do a Ctrl&Alt&F1 to get to the console?

Whatever would be on teh screen at that point in the shut-down.  The desktop 
backgroind with nothiong on it, the desktop background with a message saying 
that Trinity is shutting down, a blank screen...

I didn't try that first time (which is teh only time I have had a blank 
screen), I don't think, just as I didn't ssh in.  But I tried quite a few 
things.

> Or can you press Ctrl&Alt&Del when it hangs. Mine hang from time to time on
> shutting down timidity-daemon. I than was able to press Ctrl&Alt&Del and
> shut down proceeded. I de-installed the deamon, now the problem is gone.

At least once, I couldn't.  But I'll try again, when it happens again.

However, since I posted here it has behaved impeccably, as I predicted it 
would. ;-)

Thanks,
Lisi