trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: December 2012

Re: [trinity-users] Missing file installing Trinity on Mageia-2

From: Slávek Banko <slavek.banko@...>
Date: Tue, 4 Dec 2012 15:28:40 +0100
On Monday 03 of December 2012 19:32:15 Francois Andriot wrote:
> Le 03/12/2012 17:40, Maurice a écrit :
> > As a candidate refugee from KDE4 I have now tried installing
> > Trinity on Mageia-2.
> >
> > But although it was appearing to install well, it stopped part way
> > and warned me of a missing file:
> > -------------------------------------------------------
> > Installation failed, some files are missing:
> >
> > http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity/rpm/mga2/torn
> > -3.5.13.1-1.mga2.opt.i586.rpm
> > You may need to update your urpmi database.
> > -------------------------------------------------
> >
> > I was then given the option to continue, which I did, but the install
> > failed at the end as follows:
> >
> > -------------------------------------------------
> > installing trinity-desktop-3.5.13.1-1.mga2.noarch.rpm
> > trinity-tdepim-3.5.13.1-1.mga2.opt.i586.rpm
> > trinity-karm-3.5.13.1-1.mga2.opt.i586.rpm
> > trinity-kmobile-3.5.13.1-1.mga2.opt.i586.rpm
> > trinity-tdeartwork-emoticons-3.5.13.1-1.mga2.opt.i586.rpm
> > trinity-tdeartwork-theme-icon-3.5.13.1-1.mga2.opt.i586.rpm
> > trinity-tdeartwork-3.5.13.1-1.mga2.opt.i586.rpm from
> > /var/cache/urpmi/rpms
> > Installation failed:    trinity-korn = 3.5.13.1-1.mga2.opt is needed
> > by
> > trinity-tdepim-3.5.13.1-1.mga2.opt.i586
> > [root@laptop ~]#
> > ---------------------------------------------------
> >
> > So I have 2 questions:
> >
> >    (1) How do I obtain the missing file?
> >    (2) How could I then complete installation?
> >
> > and would much appreciate some help with this, please.
>
> Maybe it was just a temporary mirror problem, can you try again now ?
> I've just uninstalled then reinstalled this package, and it just
> installed perfectly from the official mirror ...
> Try, in order:
>    urpmi.update -a
>    urpmi trinity-korn
>    urpmi trinity-desktop
>
> Francois
>

François,

Maurice in the report said:
torn-3.5.13.1-1.mga2.opt.i586.rpm

It's just a typo Maurice, or is a typo in the dependencies in the package?

Slávek
--