trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: February 2011

Re: [trinity-users] gcc >= 4.5 - kdebase/ksmserver/shutdowndlg.cpp may need a tweak

From: "David C. Rankin" <drankinatty@...>
Date: Tue, 15 Feb 2011 19:18:34 -0600
On 02/15/2011 06:50 PM, Timothy Pearson wrote:
>> On 02/15/2011 05:17 PM, David C. Rankin wrote:
>>> Tim, Robert, all,
>>>
>>>   Building with svn rev: 1220968 I have run into the following error in
>>> kdebase/ksmserver/shutdowndlg.cpp. Given that it involves the same
>>> constructor
>>> type ‘KSMShutdownFeedback::KSMShutdownFeedback()’ as disclosed in the
>>> gcc bug,
>>> it looks to be another cmake issue that needs to be resolved.
>>>
>> <snip>
>>
>> Just a note - confirmed on both i686 & x86_64 :)
>>
>> (I know, I know -- it is what is expected, but I thought I would test both
>> anyway)
>>
>> --
>> David C. Rankin, J.D.,P.E.
> 
> OK, fixed in SVN revision 1220975.
> 
> Keep mailing this list as you find these invalid constructors, and I will
> keep fixing them! :)
> 
> Tim
> 
> 

Done :)

trinity-kdebase-1220975-1.0-i686.pkg.tar.xz

Built fine!

-- 
David C. Rankin, J.D.,P.E.