trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: August 2014

Re: [trinity-users] gcc and Trinity dependencies

From: Slávek Banko <slavek.banko@...>
Date: Sun, 24 Aug 2014 23:57:22 +0200
On Sunday 24 of August 2014 22:59:49 ant wrote:
> On Sun, 24 Aug 2014, Michele Calgaro wrote:
> > >The package kdesktop-trinity from 3.5.13.2 has a strict dependency on a
> > >particular version of binutils. You'd have to either rebuild
>
> kdebase-trinity
>
> > >with each update binutils or rebuild kdebase-trinity with build option
> > >WITH_KDESKTOP_LOCK_BACKTRACE="OFF" or use a development version R14.
> >
> > One more thing in addition to Slavek's comment.
> > Even using the development version (R14), whenever binutils is updated
> > you
>
> need to update also the package libr0, which has a strict dependency on the
>
> binutils version. Updated packages can be found on Slavek's repository:
> > http://mirror.xcer.cz/trinity-sb/dists/
> > Given the reasonable stable state of pre v14.0.0, I would suggest you
> > also
>
> update from tde 3.5.13.2 to pre v14.0.0.
>
> > Cheers
> >   Michele
>
> That has let me upgrade binutils, and it all seems stable so far!
> Had to change kde to tde in some of my scripts.
>
> Thank you for your help, folks. For reference, here is the relevant bit
> of /etc/apt/sources.list :
>
> deb http://mirror.xcer.cz/trinity-sb jessie main-r14
> deb-src http://mirror.xcer.cz/trinity-sb/ jessie main-r14
> deb http://mirror.xcer.cz/trinity-sb/ jessie deps-r14
> deb-src http://mirror.xcer.cz/trinity-sb/ jessie deps-r14
>
> cheers
>
> ant

Lines in apt sources list can be merged:

deb http://mirror.xcer.cz/trinity-sb jessie deps-r14 main-r14
deb-src http://mirror.xcer.cz/trinity-sb jessie deps-r14 main-r14

-- 
Slávek