trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: September 2014

Re: [trinity-users] can't install k9copy-trinity from nightly build repository

From: Slávek Banko <slavek.banko@...>
Date: Thu, 4 Sep 2014 17:45:01 +0200
On Thursday 04 of September 2014 14:56:30 Greg Madden wrote:
> On Thursday 04 September 2014 01:40:14 am you wrote:
> > Hi !
> >
> > I'm running trinity desktop on Debian Jessie. As I tried to install
> > k9copy program, apt-get complained about dependency on "mencoder"
> >
> > The package "mencoder" doesn't seem to be available in jessie.
> > Any idea how to solve it?
> >
> > Here is my  /etc/apt/sources.list.d/trinity.list file
> > ----8<----
> > deb
> > http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-nightly-bu
> >ilds/debian jessie main
> > deb
> > http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-nightly-bu
> >ild-dependencies/debian jessie main
> > ----8<----
> >
> > Here is the output of apt-get install command:
> > ----8<----
> > root@tuoni:~# apt-get install k9copy-trinity
> > Reading package lists... Done
> > Building dependency tree
> > Reading state information... Done
> > Some packages could not be installed. This may mean that you have
> > requested an impossible situation or if you are using the unstable
> > distribution that some required packages have not yet been created
> > or been moved out of Incoming.
> > The following information may help to resolve the situation:
> >
> > The following packages have unmet dependencies:
> >  k9copy-trinity : Depends: mencoder but it is not installable
> > E: Unable to correct problems, you have held broken packages.
> > ----8<----
> >
> > Cheers,
> >
> > Ilya Dogolazky
> >
>
> Looks like it is removed from Debian, The depends will have to be
> removed from k9copy-trinity
>
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=732159

The question is whether k9copy without MEncoder is useful? We could move 
mencoder to Recommends or set variant dependency "mencoder | libav-tools". 
But the question is whether it will be useful without rewrite k9copy to able 
use avconv instead of mencoder?

-- 
Slávek