trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: November 2014

Re: [trinity-users] trinity nightly builds uninstallable in Debian Jessie

From: Philip Ashmore <contact@...>
Date: Fri, 07 Nov 2014 11:53:04 +0000
On 06/11/14 09:59, Slávek Banko wrote:
> On Thursday 06 of November 2014 07:45:01 Timothy Pearson wrote:
>>> Hi there.
>>>
>>> I followed the instructions regarding nightly builds:
>>> $ cat /etc/apt/sources.list.d/trinity.list
>>> # Trinity nightly builds
>>> deb
>>> http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-nightly-build-
>>> dependencies/debian jessie main
>>> deb-src
>>> http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-nightly-build-
>>> dependencies/debian jessie main
>>>
>>> deb
>>> http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-nightly-builds
>>> /debian jessie main
>>> deb-src
>>> http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-nightly-builds
>>> /debian jessie main
>>>
>>> After reloading I select desktop-base-trinity [OK] and tde-trinity [FAIL]
>>> Could not mark all packages for installation or upgrade
>>> The following packages have unresolvable dependencies. Make sure that
>>> all the required repositories are added and enabled in the preferences.
>>> tde-trinity:
>>>    Depends: tde-core-trinity but it is not going to be installed
>>>    Depends: tdeedu-trinity (>=4:14.0.0~) but it is not installable
>>>    Depends: tdegames-trinity (>=4:14.0.0~) but it is not installable
>>>    Depends: tdetoys-trinity but it is not going to be installed
>>>    Depends: tdeaccessibility-trinity (>=4:14.0.0~) but it is not
>>> installable
>>>    Depends: tdeaddons-trinity (>=4:14.0.0~) but it is not installable
>>>    Depends: tdeadmin-trinity (>=4:14.0.0~) but it is not installable
>>>    Depends: tdeartwork-trinity (>=4:14.0.0~) but it is not installable
>>>    Depends: tdegraphics-trinity but it is not going to be installed
>>>    Depends: tdemultimedia-trinity (>=4:14.0.0~) but it is not installable
>>>    Depends: tdenetwork-trinity but it is not going to be installed
>>>    Depends: tdepim-trinity (>=4:14.0.0~) but it is not installable
>>>    Depends: tdeutils-trinity (>=4:14.0.0~) but it is not installable
>>>    Depends: tdewebdev-trinity (>=4:14.0.0~) but it is not installable
>>>
>>> Any ideas?
>>>
>>> Regards,
>>> Philip Ashmore
>>
>> Jessie is ay out of sync and currently rebuilding (Jessie changed some
>> core libraries that broke the existing packages).  Give it time, or use a
>> different distro and/or version that already has RC1 built at this time.
>>
>> :-)
>>
>> Tim
>>
>
> Due to change libjpeg6 => libjpeg6-turbo is necessary rebuild tqt3.
> Anyway, in my alternative apt source is already ready :)
>
$ cat /etc/apt/sources.list.d/trinity.list
# Slávek Banko's PPA
deb 
http://ppa.quickbuild.pearsoncomputing.net/slavek-banko/main-r14/ubuntu 
jessie main
deb-src 
http://ppa.quickbuild.pearsoncomputing.net/slavek-banko/main-r14/ubuntu 
jessie main
deb 
http://ppa.quickbuild.pearsoncomputing.net/slavek-banko/deps-r14/ubuntu 
jessie main
deb-src 
http://ppa.quickbuild.pearsoncomputing.net/slavek-banko/deps-r14/ubuntu 
jessie main

# apt-get update && apt-get install desktop-base-trinity tde-trinity
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  tde-trinity : Depends: tde-core-trinity (>= 4:14.0.0~) but it is not 
going to be installed
                Depends: tdeedu-trinity (>= 4:14.0.0~) but it is not 
going to be installed
                Depends: tdegames-trinity (>= 4:14.0.0~) but it is not 
going to be installed
                Depends: tdetoys-trinity (>= 4:14.0.0~) but it is not 
going to be installed
                Depends: tdeaccessibility-trinity (>= 4:14.0.0~) but it 
is not going to be installed
                Depends: tdeaddons-trinity (>= 4:14.0.0~) but it is not 
going to be installed
                Depends: tdeadmin-trinity (>= 4:14.0.0~) but it is not 
going to be installed
                Depends: tdeartwork-trinity (>= 4:14.0.0~) but it is not 
going to be installed
                Depends: tdegraphics-trinity (>= 4:14.0.0~) but it is 
not going to be installed
                Depends: tdemultimedia-trinity (>= 4:14.0.0~) but it is 
not going to be installed
                Depends: tdenetwork-trinity (>= 4:14.0.0~) but it is not 
going to be installed
                Depends: tdepim-trinity (>= 4:14.0.0~) but it is not 
going to be installed
                Depends: tdeutils-trinity (>= 4:14.0.0~) but it is not 
going to be installed
                Depends: tdewebdev-trinity (>= 4:14.0.0~) but it is not 
installable
E: Unable to correct problems, you have held broken packages.

Regards,
Philip Ashmore