trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: November 2014

Re: [trinity-users] X60s/X200s kernel 3.7.0 compiled no wifi. (Old 2.6.32, ubuntu wifi works)

From: "Dr. Nikolaus Klepp" <office@...>
Date: Fri, 7 Nov 2014 14:13:23 +0100
On wheezy (3.2 kernel and 3.12 from backports) I was not able to get the iwl3945 or any other wifi card from the T6*/X6*/X6*t series to work correctly, although they worked under 2.6 kernel. The newer models from T500 upward seem to work, but only 5 GHZ, not 2.4 GHz.

Nik

Am Donnerstag, 6. November 2014 schrieb Uwe Brauer:
> 
> Hello
> 
> Here is the short question:
> 
> Did anybody successfully compile a kernel >= 3.7, within trinity and got
> the wifi to work for the machines mentioned above??
> 
> 
> 
> ----------------------------------------------------------------
> Rationale and longer story.
> 
> I am running a X60 and an X200, both with trinity/Kubuntu 10.04 (I know it is
> outdated but I have my reasons) and wifi works without any problems.
> 
> I replaced in both machines my HHD with a SSD and reinstalled Kubuntu
> 10.04 again, using the jfs file system. I am very pleased with the
> results.
> 
> However after the installation I found out that on the long time run I
> should use trim, which was not supported for jfs in the 2.6.32-37
> kernel. I could upgrade the kernel via the backport releases but these
> backport releases did not include the kernel 3.7, which was the first
> kernel to support TRIM for jfs. So I should reinstall Kubuntu using
> either ext4 or xfs or compile  a new kernel.
> 
> So, I downloaded the 3.7.0 kernel on my X200 and run set of
> commands which I have attached belows.
> 
> Now the relevant wifi intel driver 3945 for the X60s 
> and the PRO/Wireless 5100 for the X200s seem to be compiled. 
> 
> 
> However when I boot the new kernel and run the 
> ifconfig command there is only the wired card detected but no
> wlan0 or eth0 device is found. 
> 
> I am puzzled: if I boot the 2.6.32-37 kernel I have wifi support but not
> with the 3.7 kernel. 
> 
> What should I do?
> 
> I can run sudo ifconfig wlan0 up, but knetworkmanager and wicd do not
> find the wireless card.
> 
> Any help is strongly appreciated 
> 
> Thanks 
> 
> Uwe Brauer 
> 
> 
> 
> 
> 
> I made lsmod on my X60 machine once with the new 3.7 kernel once with my
> old 2.6.32 kernel. The difference is huge in my X60 machine 
> one line is particular interesting, namely
> iwlcore               106661  1 iwl3945
> 
> 
> this line is missing for the lsmod for the 3.7.0 kernel indeed this
> module does not exist. What do I miss.
> 
> 
> I don't hope I have to recompile the kernel?
> Can somebody help me how to get the module loaded
> 
> thanks
> 
> Uwe Brauer 
> 
> 
> Commands used to compile the kernel:
> sudo make menuconfig 
> 
> sudo make 
> sudo make modules
> sudo make modules_install
> 
> make INSTALL_MOD_STRIP=1 modules_install
> sudo make install
> sudo update-initramfs -u -k 3.7.0
> 
> cd /boot/grup 
> 
> sudo cp grub.cfg grub-org.cfg
> 
> 
> su
> 
> grub-mkconfig > /boot/grub/grub.cfg
> 
> 
> sudo update-grub
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: trinity-users-unsubscribe@...
> For additional commands, e-mail: trinity-users-help@...
> Read list messages on the web archive: http://trinity-users.pearsoncomputing.net/
> Please remember not to top-post: http://trinity.pearsoncomputing.net/mailing_lists/#top-posting
> 
> 



-- 
Please do not email me anything that you are not comfortable also sharing with the NSA.

Dr. Nikolaus Klepp
Einnehmerstra├če 14
A-4810 Gmunden
Tel.: +43 650 82 11 724
email: office@...