trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: December 2014

Re: [trinity-users] a real upgrade mess

From: "Timothy Pearson" <kb9vqf@...>
Date: Sat, 20 Dec 2014 20:29:36 -0600
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA224

> said Slávek Banko:
> | On Sunday 21 of December 2014 02:39:35 dep wrote:
> | > upgrade on my notebook machine went relatively uneventfully, so i
> | > thought it safe to upgrade desktop machine. and boke everything
> | > to the extent that i do not have x on the desktop machine at all.
> | >
> | > am running ubuntu-12.04LTS
> | >
> | > from a terminal, having added the specified lines to my
> | > sources.list and commented out the old tde lines, i did:
> | >
> | > sudo apt-get update
> | > sudo aptutide upgrade
> | >
> | > due to server congestion i had to run the latter several times.
> | > it then specified a problem, to be solved by removal of
> | > libcal2b-trinity and libqt-perl.
> | >
> | > the installation blows up in a fashion too long to list here --
> | > i'd have to type it in character by characer, and it includes "25
> | > not fully installed or removed" when i went back at it with sudo
> | > apt-get dist-upgrade. that command blows up with:
> | >
> | > dpkg: error
> | > processing
> | > /var/cache/apt/archives/tdelibs-data-trinity_4%3a14.0.0-r1231-0ub
> | >untu12.04. 0+pr138_all.deb (--unpack):
> | > trying to
> | > overwrite
> | > '/opt/trinity/share/icons/crystalsvg/16x16/devices/cdrom_unmount_
> | >encrypt.pn g', which is also in package
> | > kdebase-kio-plugins-trinity
> | > 4:3.5.13.2-0ubuntu12.04.0+0
> | > dpkg-deb (subprocess): data was killed by signal (Broken pipe)
> | > dpkg-deb (subprocess): error: subprocess <decompress> returned
> | > error exit status 2
> | > Errors were encountered while
> | > processing:
> | > /var/cache/apt/archives/tdelibs-data-trinity_4%3a14.0.0-r1231-0ub
> | >untu12.04. 0+pr138_all.deb E: Sub-process /usr/bin/dpkg returned
> | > an error code (1)
> | >
> | > not real sure how to proceed. ideas?
> | >
> | > thanks.
> |
> | I see as a problem that you used 'aptitude upgrade' instead
> | 'aptitude dist-upgrade'. On my test machine I use aufs, thanks to
> | which I could re-testing of the upgrade from 3.5.13.2 to R14.0.0.
> |
> | In the case of 'aptitude dist-upgrade' on my test machine upgrade
> | always go smoothly. Where I used 'apt-get dist-upgrade' there is a
> | problem with tdelibs-data, as in your case.
>
> sorry -- i wrote it wrong. it was dist-upgrade -- i always use it when
> it says that otherwise packages will be held back.
>
> got it all installed now, apparently (only time "apt-get install -f"
> ever fixed anything for me!) and have a new problem:
>
> at startx (it makes me log in at a terminal), i get x and a box that
> says "Could not start kstartupconfig. Check your installation."
>
> so. how might i check my installation?
> --
> dep

Does ~/.xsession_errors show anything interesting?

Tim
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iFYEARELAAYFAlSWMJAACgkQLaxZSoRZrGHYNwDdHl321xD1I6oftF68PGO5FhGP
2y1TeBM9jiZM7gDeN9ZhxiG22C0It25SAXG+bOlNvwNJ8Gc7WgRyGA==
=6FXt
-----END PGP SIGNATURE-----