trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: March 2015

Re: Kontact / Kmail crashed (was Repo not reachable)

From: Gerhard Zintel <gerhard.zintel@...>
Date: Tue, 31 Mar 2015 20:59:36 +0200
On Tuesday 31 March 2015, Slávek Banko wrote:
> On Saturday 28 of March 2015 13:17:17 Gerhard Zintel wrote:
> > Some comments:
> >
> > I had a serious problem with updating to the latest R14.0.1
> > version (worth a differrent mail) from
> >   deb http://mirror.xcer.cz/trinity-sb raring deps-r14 main-r14
> >
> > After update Kontact crashed badly, Kmail opened once, was unable
> > to send (no response after trying to send) and crashed after
> > killing it with "kill ..." constantly. Thus access to my old
> > mails - very bad.
>
> This is for me very interesting. I use KMail from TDE R14.0.1
> (preliminary) every day and have not noticed problems. I use KMail
> alone - without Kontact. For you crashes occur in both cases? With
> and without Kontact?

Hi Slávek,

thanks a bunch for your interest. I try to elaborate as good as I 
remember:

I was since some time (months) on R14.0.1 from mirror mentioned above 
but without constantly updating. I had severe problems with gnuplot 
(using term x11) that - very often - crashed TDE in one instant 
without any message / notice anywhere. Very anoying! All open windows 
gone, I hat to logg-in again and recreate my working environment.

That was the reason to upgrade to the latest version of R14.0.1. 
Unfortunately I can not remember if I used apt-get upgrade or 
dist-upgrade. All packeges have been updated successfully. Some time 
later, I realized that I no longer could launch Kontak with its icon. 
I launched it from Konsole and got the error message I described in 
my latest post.

For I mainly use Kmail from Kontakt I launched Kmail from Konsole and 
it opened and downloaded new mails. But trying to send a mail Kmail 
froze in sending and I was not able to stop the send process or to 
terminate Kmail by any button or menu entry. So I had to kill it.

Afterwards I was not longer able to launch Kmail. It crashed at once 
with a message I can not remember. For my guess was that it was due 
to the upgrade, I tried to downgrade to a save state (R14.0.0) with 
some troubles (described in the other mail). 

After sucessfully deleting all TDE packages R14.0.1 and reinstalling 
R14.0.0 still I was not able to launch Kontakt or Kmail. I created a 
new testuser and logged in with a fresh .trinity folder. Kmail 
worked. Obviously something was broken in my .trinity settings. I 
tried to compare both folders / subfolders with "meld" without 
success.

Fortunately I hat a 2 month old backup of the .trinity folder that I 
restored. Afterwards Kontakt and Kmail worked again like a charm. So 
I suspect if I upgrade again to R14.0.1 it might work as well with 
the repaired .trinity folder but I have not yet tested (it's a 
production machine and I can not allow it to chrash again).

Nonetheless if I can do anything for further investigation please let 
me know.

Gerhard

PS: gnuplot still crashs X often when using (set term x11) for the 
graphical output. I meanwhile compiled latest version myself and use 
now "set term qt" as the graphical terminal that works without a 
hickup. I'm a bit surprised that an application is able to chrash X 
from one moment to the next.