trinity-users@lists.pearsoncomputing.net

Message: previous - next
Month: July 2015

Re: [trinity-users] Plugged media notifier not opening precise 12.04

From: Slávek Banko <slavek.banko@...>
Date: Tue, 21 Jul 2015 19:47:00 +0200
Dne čt 16. července 2015 Nigel Henry napsal(a):
> My usb harddrive will not open the plugged media notifier on Precise 12.04
> with TDE 3.5.13.2.
>
> If I log out and back in to the xfce4 desktop the usb harddrive is detected
> and mounts ok.
>
> I also have Lucid 10.04 with TDE and Hardy 8.04 with KDE3 on the same
> machine and the plugged media notifier works ok on them.
>
> On a new machine I have recently installed Precise 12.04 with TDE 3.5.13.2
> which installed with no problems whatsoever (Asrock M3A785GM-LE/128M) and
> the plugged media notifier works as expected.
>
> On the Precise 12.04 with the problem, I ran tail -f /var/log/syslog and
> the usb harddrive is detected ok and shows the two partitions on it as
> below.
>
> Jul  7 12:30:28 ubuntu-desktop kernel: [ 5924.180024] usb 1-7: new
> high-speed USB device number 4 using ehci_hcd
> Jul  7 12:30:28 ubuntu-desktop kernel: [ 5924.248237] hub 1-0:1.0: unable
> to enumerate USB device on port 7
> Jul  7 12:30:28 ubuntu-desktop kernel: [ 5924.704028] usb 2-7: new
> full-speed USB device number 4 using ohci_hcd
> Jul  7 12:30:28 ubuntu-desktop kernel: [ 5924.904956] usb 2-7: not running
> at top speed; connect to a high speed hub
> Jul  7 12:30:28 ubuntu-desktop kernel: [ 5924.934473] usb-storage 2-7:1.0:
> Quirks match for vid 152d pid 2329: 8020
> Jul  7 12:30:28 ubuntu-desktop kernel: [ 5924.936142] scsi7 : usb-storage
> 2-7:1.0
> Jul  7 12:30:28 ubuntu-desktop mtp-probe: checking bus 2, device 4:
> "/sys/devices/pci0000:00/0000:00:02.0/usb2/2-7"
> Jul  7 12:30:28 ubuntu-desktop mtp-probe: bus: 2, device: 4 was not an MTP
> device
> Jul  7 12:30:29 ubuntu-desktop kernel: [ 5925.944980] scsi 7:0:0:0:
> Direct-Access     WDC WD50 00AAKX-00ERMA0   15.0 PQ: 0 ANSI: 2 CCS
> Jul  7 12:30:29 ubuntu-desktop kernel: [ 5925.951726] sd 7:0:0:0: Attached
> scsi generic sg6 type 0
> Jul  7 12:30:29 ubuntu-desktop kernel: [ 5925.958973] sd 7:0:0:0: [sde]
> 976773168 512-byte logical blocks: (500 GB/465 GiB)
> Jul  7 12:30:29 ubuntu-desktop kernel: [ 5925.971984] sd 7:0:0:0: [sde]
> Write Protect is off
> Jul  7 12:30:29 ubuntu-desktop kernel: [ 5925.971989] sd 7:0:0:0: [sde]
> Mode Sense: 28 00 00 00
> Jul  7 12:30:29 ubuntu-desktop kernel: [ 5925.984971] sd 7:0:0:0: [sde] No
> Caching mode page found
> Jul  7 12:30:29 ubuntu-desktop kernel: [ 5925.984977] sd 7:0:0:0: [sde]
> Assuming drive cache: write through
> Jul  7 12:30:29 ubuntu-desktop kernel: [ 5926.022515] sd 7:0:0:0: [sde] No
> Caching mode page found
> Jul  7 12:30:29 ubuntu-desktop kernel: [ 5926.022519] sd 7:0:0:0: [sde]
> Assuming drive cache: write through
> Jul  7 12:30:29 ubuntu-desktop kernel: [ 5926.042053]  sde: sde1 sde2
> Jul  7 12:30:29 ubuntu-desktop kernel: [ 5926.110974] sd 7:0:0:0: [sde] No
> Caching mode page found
> Jul  7 12:30:29 ubuntu-desktop kernel: [ 5926.110979] sd 7:0:0:0: [sde]
> Assuming drive cache: write through
> Jul  7 12:30:29 ubuntu-desktop kernel: [ 5926.110983] sd 7:0:0:0: [sde]
> Attached SCSI disk
> Jul  7 12:30:54 ubuntu-desktop kernel: [ 5950.279533] usb 2-7: USB
> disconnect, device number 4
> ^Cdjmons@ubuntu-desktop:~$
>
> I get the same as the above with the new install of Precise 12.04 but then
> the plugged media notifier opens and when I click on ok I get a few more
> lines of output and the harddrive is mounted and opens the partitions in
> konqueror.
>
> Apart from reinstalling TDE default settings and the desktop has anyone any
> suggestions as to how to troubleshoot the problem that TDE seems to have in
> opening the plugged media notifier on this install?
>
> Thanks in advance,
> Nigel.
>

If I remember correctly, on Ubuntu Precise was sometime problem with the 
proper functioning of HAL. And because notifications of the media in TDE 
3.5.13.x depends on HAL, you must first verify the functionality of HAL.

...or you can upgrade to the TDE R14 series, which no longer needs to HAL.

-- 
Slávek